DHCP-Server einrichten/No subnet declaration for eth0 (0.0.0.0).

debian user german

Claudius
Hallo Liste,

seite geraumer Zeit versuche ich, auf einem Debian 3.1 Sarge einen
DHCP-Server einzurichten. Der Start des Servers bricht jedoch immer mit

Starting DHCP server: dhcpd3 failed to start - check syslog for diagnostics.

ab, tail /var/log/syslog sagt nur:

--snip--










-/snip--

Das Netzwerk hier sieht in etwa so aus:

			Router [1]
			|       |
		       PC1  Router [2]
				|
			     Switch
                              |   |
			     PC2 PC3

[1] ist ein Conceptronic C100BRS4H
PC1 ist ein Win98
[2] kennzeichnet den Beginn "meines" Netzwerkes, o. g. Debian Sarge 3.1-Router
PC2 + PC3 sind Debain Testing/Sid-Maschinen

Warum das ganze? - [1] bietet nur sehr wenige Möglichkeiten, ich möchte
aber z. B. auch einen DNS-Server sowie die Vergabe nach MAC-Adressen.
=> Zweiter Router, dann gleich noch mit Firewall etc. etc.

[1] vergibt mittels DHCP Adressen von 192.168.2.100-200, IP 192.168.2.1

Meine Konfigurationsdateien auf [2] hab ich unten angehängt,
vorgegangen bin ich nach
http://www.online-tutorials.net/internet-netzwerk/routing-tutorial/tutorials-t-29-106.html

Für Hilfe wäre ich wirklich dankbar, da sich mit Google leider zu dem
Thema nichts passendes finden lässt - und mit alternativen
Suchmaschinen auch nicht :(.


Mit freundlichen Grüßen

Claudius

/etc/default/dhcp3-server:
INTERFACES="eth0"

/etc/network/interfaces:
auto lo eth0
iface lo inet loopback

#EXTERN
auto eth1
iface eth1 inet dhcp

#INTERN
iface eth0 inet static  
   address 192.168.0.1 
   netmask 255.255.255.0 
   network 192.168.0.0 
   broadcast 192.168.0.255

/etc/dhcp3/dhcp.conf
#ddns-update-style none;

subnet 192.168.0.0 netmask 255.255.255.0 
{ 
    range 192.168.0.50 192.168.0.100; 
    option domain-name "x2017.homelinux.org"; 
    option domain-name-servers 192.168.0.1; 
    option routers 192.168.0.1; 
    option broadcast-address 192.168.0.255; 
    default-lease-time 86400; 
    max-lease-time 604800; 
} 

Habe es hier auch mit nicht-auskommentiertem ddns-update-style none; probiert, gleiches Ergebnis.
                                            
Claudius
Hat sich erledigt, es muss einem ja auch gesagt werden, dass man vorher
die entsprechende Netzwerkkarte mit ifup et0 "uplinken" muss.

Entschuldigt bitte die Störung..

Greetings

Claudius